Voter ID

Colin Powell Says NC Voter ID Law Punishes Minorities

Photo ID will be required to vote from 2016 onwards

|

RALEIGH, N.C., Aug. 22 (UPI) — Former U.S. Secretary of State Colin Powell said Thursday new changes in North Carolina voting law punish minority voters and will hurt Republicans.

Powell, in a speech at the North Carolina CEO Forum in Raleigh—an annual gathering of private and public sector executives and managers—Powell said the state's new voter ID law is not even necessary because there is no evidence of the kind of voter fraud its backers said it was designed to address.